CRAN Package Check Results for Package EpiSignalDetection

Last updated on 2021-09-16 16:50:12 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.1 4.33 46.94 51.27 OK
r-devel-linux-x86_64-debian-gcc 0.1.1 3.90 36.22 40.12 OK
r-devel-linux-x86_64-fedora-clang 0.1.1 71.95 NOTE
r-devel-linux-x86_64-fedora-gcc 0.1.1 59.19 NOTE
r-devel-windows-x86_64 0.1.1 7.00 70.00 77.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.1.1 NOTE
r-patched-linux-x86_64 0.1.1 4.46 44.46 48.92 OK
r-patched-solaris-x86 0.1.1 76.80 ERROR
r-release-linux-x86_64 0.1.1 4.29 44.60 48.89 OK
r-release-macos-arm64 0.1.1 ERROR
r-release-macos-x86_64 0.1.1 ERROR
r-release-windows-ix86+x86_64 0.1.1 10.00 69.00 79.00 OK
r-oldrel-macos-x86_64 0.1.1 ERROR
r-oldrel-windows-ix86+x86_64 0.1.1 26.00 60.00 86.00 OK

Check Details

Version: 0.1.1
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘ggplot2’ ‘knitr’ ‘pander’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-windows-x86_64-gcc10-UCRT, r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 0.1.1
Check: examples
Result: ERROR
    Running examples in ‘EpiSignalDetection-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: runEpiSDReport
    > ### Title: Run the EpiSignalDetection report (HTML markdown)
    > ### Aliases: runEpiSDReport
    >
    > ### ** Examples
    >
    > #---> OR
    >
    > #-- First setting the parameters to run the report for
    > input <- list(
    + disease = "Salmonellosis",
    + country = "Portugal",
    + indicator = "Reported cases",
    + stratification = "Confirmed cases",
    + unit = "Month",
    + daterange = c("2011-01-01", "2016-12-31"),
    + algo = "FarringtonFlexible",
    + testingperiod = 6
    + )
    >
    > #-- Second running the report based on the EpiSignalDetection::SignalData dataset
    > #-- and store it in a temporary folder
    > runEpiSDReport(input = input)
    Error: pandoc version 1.12.3 or higher is required and was not found (see the help page ?rmarkdown::pandoc_available).
    Execution halted
Flavors: r-patched-solaris-x86, r-release-macos-arm64, r-release-macos-x86_64, r-oldrel-macos-x86_64