CRAN Package Check Results for Package ggcoverage

Last updated on 2023-06-02 18:52:45 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.7.1 69.60 663.47 733.07 OK
r-devel-linux-x86_64-debian-gcc 0.7.1 54.14 507.15 561.29 OK
r-devel-linux-x86_64-fedora-clang 0.7.1 938.25 NOTE
r-devel-linux-x86_64-fedora-gcc 0.7.1 975.63 OK
r-devel-windows-x86_64 0.7.1 63.00 469.00 532.00 NOTE
r-patched-linux-x86_64 0.7.1 OK
r-release-linux-x86_64 0.7.1 66.28 646.97 713.25 OK
r-release-macos-arm64 0.7.1 254.00 ERROR
r-release-macos-x86_64 0.7.1 526.00 ERROR
r-release-windows-x86_64 0.7.1 79.00 642.00 721.00 NOTE
r-oldrel-macos-arm64 0.7.1 11.00 ERROR
r-oldrel-macos-x86_64 0.7.1 11.00 ERROR
r-oldrel-windows-x86_64 0.7.1 77.00 553.00 630.00 NOTE

Check Details

Version: 0.7.1
Check: package dependencies
Result: NOTE
    Imports includes 21 non-default packages.
    Importing from so many packages makes the package vulnerable to any of
    them becoming unavailable. Move as many as possible to Suggests and
    use conditionally.
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 0.7.1
Check: installed package size
Result: NOTE
     installed size is 7.1Mb
     sub-directories of 1Mb or more:
     doc 5.2Mb
     extdata 1.2Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-x86_64, r-release-macos-arm64, r-release-macos-x86_64, r-release-windows-x86_64, r-oldrel-windows-x86_64

Version: 0.7.1
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘BSgenome.Hsapiens.UCSC.hg19’
Flavors: r-release-macos-arm64, r-release-macos-x86_64

Version: 0.7.1
Check: examples
Result: ERROR
    Running examples in ‘ggcoverage-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: geom_base
    > ### Title: Add Base and Amino Acid Annotation to Coverage Plot.
    > ### Aliases: geom_base
    >
    > ### ** Examples
    >
    > library(ggcoverage)
    > library("BSgenome.Hsapiens.UCSC.hg19")
    Error in library("BSgenome.Hsapiens.UCSC.hg19") :
     there is no package called 'BSgenome.Hsapiens.UCSC.hg19'
    Execution halted
Flavors: r-release-macos-arm64, r-release-macos-x86_64

Version: 0.7.1
Check: package dependencies
Result: ERROR
    Package required but not available: ‘ggbio’
    
    Package suggested but not available for checking: ‘BSgenome.Hsapiens.UCSC.hg19’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavors: r-oldrel-macos-arm64, r-oldrel-macos-x86_64